Вопрос по информатике:
Помогите с Паскалем ABS.
1 дано пятизначное число. определить сумму второй и пятой цифры.
2 дано пятизначное число. Определить сумму второй и четвёртой цифрой.
3 написать программу в которой подсчитывается количество чётных чисел среди трёх, введёных с клавиатуры
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 23.12.2015 10:09
- Информатика
- remove_red_eye 5111
- thumb_up 35
Ответы и объяснения 2
№2.
var a,b: integer;
beginreadln(a);
b:=a;
a:= (a div 10) mod 10;
b:= (b div 1000) mod 10;
writeln(b+a);
end.
№1.
var a,b: integer;
beginreadln(a);
b:=a;
a:= a mod 10;
b:= (b div 1000) mod 10;
writeln(b+a);
end.
- 24.12.2015 20:13
- thumb_up 45
№ 1-2
var x, t, f, l, sum, sum2: integer;
begin
write('Введите x: ');
readln(x);
if ( x 99999 ) then
writeln('Ошибка. Число не пятизначное!')
else
begin
l := x mod 10;
t := (x div 1000 mod 10);
sum := l + t;
f := (x div 10 mod 10);
sum2 := t + f;
writeln('Сумма второй и последней цифры: ', sum);
writeln('Сумма второй и четвертой цифры: ', sum2);
end;
end.
№3
var a, b, c, rez: integer;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
rez := 0;
if a mod 2 = 0 then inc(rez);
if b mod 2 = 0 then inc(rez);
if c mod 2 = 0 then inc(rez);
writeln('Количество четных чисел: ', rez);
end.
- 25.12.2015 03:42
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.