Вопрос по информатике:
Дано трехзначное число.Найти сумму цифр числа.(Написать программу на языке Паскаль)
- 22.03.2018 01:47
- Информатика
- remove_red_eye 18413
- thumb_up 28
Ответы и объяснения 2
Program chisla;
uses crt;
var a,b,c,d : integer;
begin
Writeln('Введите трехзначное число: ');
Readln(a);
if (a999) then writeln('Введено не трехзначное число')
else
begin
b:=a div 100;
c:=(a-(b*100)) div 10;
d:=a-(b*100)-(c*10);
Writeln('Сумма цифр этого числа равна ',b+c+d);
end
end.
- 24.03.2018 23:12
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.