Вопрос по информатике:
Используя сначала цикл с условием, а затем - цикл с переменной, напишите программу, которая выводит на экран четные степени числа 2 от до
в порядке убывания
- 10.05.2018 00:03
- Информатика
- remove_red_eye 16812
- thumb_up 6
Ответы и объяснения 1
Четные степени числа 2 - это все равно что целые степени числа 4 от до
.
Программы на Pascal:
program first;
var i:integer;
begin
i:=1024;
while i>1 do begin
writeln(i);
i:=i div 4;
end;
end.
program second;
var i,pow:integer;
begin
i:=1024;
for pow:=5 downto 1 do begin
writeln(i);
i:=i div 4;
end;
end.
- 01.01.1970 00:00
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.