Вопрос по информатике:
Помогите выполнить это задание по информатике:
Составить программу на языке Паскаль для решения следующей задачи: задать одномерный массив случайным образом, элементы которого принадлежат промежутку [-30;20] и найти наименьший элемент среди положительных элементов (учесть вариант, когда в массиве может не оказаться положительных элементов).
Прошу учесть правильность написания самой программы (Чтобы можно было вставить в паскаль и не исправлять чужие ошибки.(Я ещё в своих не разбираюсь))
- 27.08.2017 07:27
- Информатика
- remove_red_eye 11327
- thumb_up 19
Ответы и объяснения 1
Const
n = 3;
var
i,b:integer;
a:array[1..n] of integer;
begin
b:=21;
for i:=1 to n do
begin
a[i]:=random(51)-30;
if (a[i]>0) and (a[i] end;
writeln('Полученный массив:');
for i:=1 to n do
write('a[':4,i,']=',a[i]);
writeln;
if b<21 then write('Наименьший элемент = ',b) else write('Нет положительных элементов')
end.
- 28.08.2017 23:20
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.