Вопрос по информатике:
Написать программу, состоящую из 30 чисел, числа понимают значения от -500 до 500, программа находит минимальное значение среди нечетных элементов массива, которые кратны 5.
- 11.07.2015 02:55
- Информатика
- remove_red_eye 12969
- thumb_up 28
Ответы и объяснения 1
Const
n = 30;
var
x: array[1..n] of integer;
i, t, min: integer;
begin
Randomize;
Writeln('Элементы массива');
min:=32767;
for i := 1 to n do
begin
t := Random(1001)-500;
x[i] := t;
Write(t:5);
if Odd(i) and (t mod 5 = 0) and (min>t) then min:=t
end;
Writeln;
Writeln('Минимальный нечетный элемент, кратный 5, равен ',min)
end.
Тестовое решение:
Элементы массива
-64 438 -290 358 -424 234 -444 -17 171 -57 -373 -279 242 -403 -262 34 -488 365 341 -468 163 -276 193 -140 126 -466 -236 -34 350 -369
Минимальный нечетный элемент, кратный 5, равен -290
- 12.07.2015 21:05
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.