Вопрос по информатике:
Вычислить сумму натуральных чисел от 1 до N .
Составить программу нахождения кол-ва делителей числа N ( значение N вводится с клавиатуры )
- 07.01.2018 01:19
- Информатика
- remove_red_eye 18700
- thumb_up 14
Ответы и объяснения 1
Держи!
1)
var i,n,result:integer;
begin
read(n);
result:=0;
for i:=1 to n do
begin
result:=result+i;
end;
write(result);
end.
2)
var i,n,increase,result:integer;
massive = array[1..1000] of integer;// ищем делители в диапазоне 1-1000
begin
read(n);
for i:=1 to 1000 do
begin
if((n mod massive[i])=0) then
begin
increase:=increase + 1;
end;
end;
result:=increase;
write(result);
end.
- 08.01.2018 08:27
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.