Вопрос по информатике:
Алгоритм евклида для вычисления нод двух натуральных чисел формируется так нужно заменять большее число на разность большего и меньшего до тех пор пока одно из них не станет равно нулю тогда второе и есть нод напишите программу которая реализует этот алгоритм какой цикл тут нужно использовать
- 15.11.2017 08:54
- Информатика
- remove_red_eye 12065
- thumb_up 7
Ответы и объяснения 1
Var
a,b:integer;
begin
Write('Введите два натуральных числа '); Readln(a,b);
while ab do
if a > b then a := a - b
else b := b - a;
Writeln('НОД=',a)
end.
Тестовое решение:
Введите два натуральных числа 28 16
НОД=4
- 16.11.2017 05:15
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.