Вопрос по информатике:
СРОЧНО ПЛИЗ НАРОД!!!!
Даны коэффициенты квадратного уравнения a,b,c.Напишите программу которая решает это квадратное уравнение.(в Паскале)
- 11.12.2017 22:26
- Информатика
- remove_red_eye 6522
- thumb_up 37
Ответы и объяснения 2
Program Uravnenie;
uses Crt;
var a,b,c,x,x1,x2 : real ;
begin
clrscr;
writeln ( 'Введите a : ' );
readln ( a );
writeln ( 'Введите b : ' );
readln ( b );
writeln ( 'Введите c : ');
readln ( c );
if ( sqr ( b ) - 4 * a * c ) < 0
then writeln ( ' Уравнение не имеет решения ' ) else begin
if ( sqr ( b ) - 4 * a * c ) = 0
then begin
x:= - b / ( 2 * a );
writeln( ' x = ', x : 8 : 2 )
end
else
begin
x1:= ( - b + sqrt ( sqr ( b ) - 4 * a * c ) ) / ( 2 * a );
x2:= ( - b - sqrt ( sqr ( b ) - 4 * a * c ) ) / ( 2 * a );
writeln( ' x1 = ', x1 : 8 : 2, ' x2 = ', x2 : 8 : 2 )
end
end.
- 12.12.2017 07:06
- thumb_up 39
Program s;
var a,b,c,x,z,d:real;
begin
write('Введите a,b,c');
read(a,b,c);
d:=(b*b)-(4*a*c);
if d<0 then write(' Уравнение не имеет корней')
else
x:=(-b+sqrt(d))/(2*a);
z:=(-b-sqrt(d))/(2*a);
write(' х равно ',x, ', ', z);
end.
- 14.12.2017 00:17
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.