Вопрос по информатике:
Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом
- 15.04.2017 12:21
- Информатика
- remove_red_eye 5339
- thumb_up 35
Ответы и объяснения 1
Var
s: string;
i, j, n: integer;
c: char;
flag: boolean;
begin
Write('Введите произвольное число: '); Readln(s);
flag := false;
n := length(s);
i := 1;
while (i <= n) and (not flag) do
begin
c := s[i];
j := i + 1;
while (j <= n) and (not flag) do
if s[j] = c then flag := true else j := j + 1;
if (not flag) then i := i + 1
end;
if flag then Writeln('Символ "', c, '" встречается больше одного раза')
else Writeln('Все символы уникальны')
end.
Тестовое решение:
Введите произвольное число: 16379068
Символ "6" встречается больше одного раза
- 16.04.2017 19:15
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.