Вопрос по информатике:
Факториалом числа 5 (обозначается 5!) называется значение следующего выражения: f=1*2*3*4*5. Составьте программу, которая запросив у пользователя целое число n, вычислит значение факториала числа. (Линейное программирование, цикл с параметром)
- 22.09.2016 18:26
- Информатика
- remove_red_eye 14780
- thumb_up 36
Ответы и объяснения 1
Var
i,n,p:longint;
begin
Write('Введите целое число n -> '); Readln(n);
p:=1;
for i:=2 to n do p:=p*i;
Writeln('n!=',p)
end.
Тестовое решение:
Введите целое число n -> 5
n!=120
- 23.09.2016 09:10
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.