Вопрос по информатике:
Срочно! очень надо!
напишите программу вычисления наименьшего общего кратного следующих четырех чисел: 36 54 18 и 15. Используйте процедуру вычисления общего делителя двух чисел
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 16.11.2016 06:33
- Информатика
- remove_red_eye 15382
- thumb_up 13
Ответы и объяснения 1
Function gcd(a,b: longint): longint;
{ Нахождение НОД }
var
i: longint;
begin
while b 0 do
begin
a := a mod b;
i := b; b := a; a := i
end;
gcd := a
end;
function lcm(a,b:longint):longint;
{ Нахождение НОК }
begin
lcm:=a*b div gcd(a,b)
end;
begin
Writeln('НОД(36;54;18;15)=',lcm(36,lcm(54,lcm(18,15))))
end.
Результат выполнения программы:
НОД(36;54;18;15)=540
- 17.11.2016 13:29
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.