Вопрос по информатике:
Дано целое трехзначное положительное число n. составьте программу которая определяет входит ли в него цифра восемь. помогите пожалуйста!!!!!!!!
- 12.08.2017 00:09
- Информатика
- remove_red_eye 1985
- thumb_up 26
Ответы и объяснения 2
Const ch=8;
var n:integer;
begin
read(n);
while n>0 do begin
if(n mod 10=ch)then begin
writeln('yes'); break;
end;
n:=n div 10;
end;end.
еще можно в строку преобразовать и посимвольно проверить, но мне кажется так нагляднее и алгоритм проще
- 13.08.2017 00:34
- thumb_up 40
Var x:integer; Begin readln (x); If (x div 10) or (x div 10 mod 10) or (x mod 10)=8 then writeln ('yes') else writeln ('no'); Readln end.
- 14.08.2017 22:14
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.