Вопрос по информатике:
Пожалуйста решит оч надо
Условная инструкция
Задача «Шахматная доска»
Заданы две клетки шахматной доски. Если они покрашены в один цвет, то выведите слово YES, а если в разные цвета — то NO. Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки.
- 05.12.2016 21:48
- Информатика
- remove_red_eye 14960
- thumb_up 21
Ответы и объяснения 1
Var
a1,a2,b1,b2,c1,c2:integer;
begin
writeln('Координаты превой клетки');
writeln('введите номер столбца');
readln(a1);
writeln('введите номер строки');
readln(a2);
writeln('Координаты второй клетки');
writeln('введите номер столбца');
readln(b1);
writeln('введите номер строки');
readln(b2);
if ((a1 mod 2) 0) then
if ((a2 mod 2) 0) then c1:=0 else c1:=1;
if ((a1 mod 2) = 0) then
if ((a2 mod 2) 0) then c1:=1 else c1:=0;
if ((b1 mod 2) 0) then
if ((b2 mod 2) 0) then c2:=0 else c2:=1;
if ((b1 mod 2) = 0) then
if ((b2 mod 2) 0) then c2:=1 else c2:=0;
if c1=c2 then writeln('YES') else writeln('NO')
end.
- 06.12.2016 18:56
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.