Вопрос по информатике:
Ваш друг предлагает вам переписать отснятый им видеофильм. Из носителей информации у вас есть: компакт-диск объемом 650 МБ, дискета объемом 1МБ и флеш-накопитель объемом 1000Мб. Напишите программу, перечисляющую все носители, на которые полностью поместится фильм. Объем видеофайла задается в мегабайтах.
- 27.09.2018 05:11
- Информатика
- remove_red_eye 15579
- thumb_up 18
Ответы и объяснения 1
Var
d:integer;
const
a=650;
b=1;
c=1000;
begin
write('Введите объём видеофайла в мегабайтах: ');
readln(d);
if d>a then write('Видеофайл не помещается на носитель информации"А"!',#10) else
writeln('Памяти хватает для записи на носитель "А"! ',#10);
if d>b then write('Видеофайл не помещается на носитель информации"B"!',#10) else
writeln('Памяти хватает для записи на носитель "B"! ',#10);
if d>c then write('Видеофайл не помещается на данный носитель информации"С"!',#10) else
writeln('Памяти хватает для записи на носитель "C"! ',#10);
readln;
end.
- 28.09.2018 17:07
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.