Вопрос по информатике:
Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел
(массив не использовать).Сделайте три варианта программы,используя операторы While,Repeat ,For. СРОЧНО !!!! Заранее Спасибо
- 20.08.2017 20:44
- Информатика
- remove_red_eye 14226
- thumb_up 6
Ответы и объяснения 1
Int a, tmp1 = 0, tmp2 = 0;
1)while (tmp < 10) {
cin >> a;
tmp2 += a; }
cout << tmp2 / 10;
2)for (; tmp < 10; tmp++) {
cin >> a;
tmp2 += a; }
cout << tmp2 / 10;
3)repeat
cin >> a;
tmp2 += a;
until (tmp < 10)
cout << tmp2 / 10;
- 21.08.2017 15:07
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.