Вопрос по информатике:
Написать программу, которая получает случайное целое типа int, выводит его двоичное представление на экран, выполняет преобразование в соответствии с вариантом (см. ниже), затем выводит на экран двоичное представление результата преобразования.
№ варианта Задание Пример
1 Изменить порядок следования битов в числе на обратный 11010011 11001011
язык Си
- 12.11.2016 02:02
- Информатика
- remove_red_eye 12137
- thumb_up 42
Ответы и объяснения 1
Void dvoich(int x1) {
srand (time(NULL));
int i, b;
long c = 0;
x1 = rand();
for(i=0;x1 > 0;i++) {
b = x1 % 2;
x1 = (x1-b)/2;
c += b * pow(10,i); }
printf("\nDvoichnoe chislo: %d",c); }
reverse(c.begin(), c.end());
printf("\nDvoichnoe obratnoe chislo: %d",c);
- 13.11.2016 17:01
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.