Вопрос по информатике:
Помогите написать программу на паскале
Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от -10000 до 10000 включительно. Опишите на естественном языке или на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, сумма которых четна и положительна. Под парой подразумевается два подряд идущих элемента массива.
- 14.01.2018 05:15
- Информатика
- remove_red_eye 2706
- thumb_up 28
Ответы и объяснения 1
Program gt;
var a:array[1..20]of longint;
i,h:longint;
begin
for i:=1 to 20 do
read(a[i]);
for i:=1 to 19 do
if((a[i]+a[i+1]>0)and((a[i]+a[i+1])mod 2=0))then h:=h+1;
writeln(h);
end.
- 16.01.2018 00:35
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.