Вопрос по информатике:
Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z.
Программа должна выводить соответствующее текстовое сообщение. Программист сделал в программе ошибки.
var х, у, z: real;
begin
readln (x, у, z);
if (x + y > z) then
begin
if (x + z > y) then
if (y + z > x) then
writeln('треугольник построить можно');
end
else writeln('треугольник построить нельзя');
end
Последовательно выполните задания:
1. Приведите пример таких чисел х, у, z, при которых программа неверно решает поставленную задачу.
2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы (можно указать один из
способов доработки исходной программы).
3. Укажите, как можно доработать программу, чтобы она вместо вложенных операторов IF содержала логическую операцию
AND.
Нужен подробный ответ.
- 24.08.2017 00:56
- Информатика
- remove_red_eye 2421
- thumb_up 27
Ответы и объяснения 1
Если ввести X или Y значительно больше чем Z то программа на втором или тертьем условии выдаст false и закончит свою работу ничего не написав. Например: если указать X = 10 , Y = 2, Z = 3; то на первом условии будет true, потому что 10 +2 > 3 , но на третьем условии выдаст false потому что 2+3 < 10 но так как ничего не прописано на этот случай программа просто закончит свою работу.
Что бы исправить этот баг необходимо все условия свести в одно:
if ((x + y > z)and (x + z > y) and (y + z > x) ) then
writeln('треугольник построить можно')
else
writeln('треугольник построить нельзя');
end.
------------------------------------
Это решение так же является ответом на 3-й вопрос.
- 25.08.2017 15:57
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.