Вопрос по информатике:
Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 22:
var i, k: integer;
function F(x:integer):integer;
begin
F:=x*x*x+x*x;
end;
begin
i := 20;
readln(K);
while (i > 0) and (F(i) > K) do
i:=i-1;
writeln(i);
end.
- 12.02.2016 22:50
- Информатика
- remove_red_eye 10902
- thumb_up 49
Ответы и объяснения 1
У тебя функция x^3+x^2 и перебор от 20 до 1, т.е. x^3+x^2 будет больше 22 при числах:
20, 19, 18, 17, 16, 15, 14, 13, 12, 11, 10, 9, 8, 7, 6, 5, 4, 3.
итого: 18 чисел
- 13.02.2016 10:22
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.