Вопрос по информатике:
Помогите пожалуйста с этими примерами
1) Определите значение целочисленных переменных x и y после выполнения фрагмента программы:
x := 336
У := 8;
x := x div y;
y := х mod у;
2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:
а :=1686;
b :=(a div 10) mod 5;
а := а - 200*b;
3)Определите значение целочисленных переменных x и y после выполнения фрагмента программы:
х := 11;
у := 5;
t := y;
у := х mod у;
x := t;
у := у + 2*t;
4) Определите значение целочисленных переменных x и y после выполнения фрагмента программы:
х := 19;
у := 3;
z := у*2;
у := х mod у;
х := х - z;
у := у + z;
5)Определите значение целочисленных переменных x, y и z после выполнения фрагмента программы:
х := 13;
у := 3;
z := x;
x := z div у;
у := х;
- 09.09.2018 08:47
- Информатика
- remove_red_eye 10513
- thumb_up 29
Ответы и объяснения 1
Код
var
x, y, z, a, b, c, d, t: integer ;
begin
x := 336;
y := 8;
x := x div y;
y := x mod y;
writeln('x = ', x, ', y = ', y);
a := 1686;
b := (a div 10) mod 5;
a := a - 200 * b;
writeln('a = ', a, ', b = ', b);
x := 11;
y := 5;
t := y;
y := x mod y;
x := t;
y := y + 2 * t;
writeln('x = ', x, ', y = ', y, ', t = ', t);
x := 19;
y := 3;
z := y * 2;
y := x mod y;
x := x - z;
y := y + z;
writeln('x = ', x, ', y = ', y, ', z = ', z);
x := 13;
y := 3;
z := x;
x := z div y;
y := x;
writeln('x = ', x, ', y = ', y, ', z = ', z);
end.
Вывод и ответы по очереди
1) x = 42, y = 2
2) a = 1086, b = 3
3) x = 5, y = 11, t = 5
4) x = 13, y = 7, z = 6
5) x = 4, y = 4, z = 13
- 01.01.1970 00:00
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.