Вопрос по информатике:
Дан одномерный массив целых чисел.Написать программу подсчёта количества положительных и отрицательных чисел массива.
- 23.09.2018 05:53
- Информатика
- remove_red_eye 18711
- thumb_up 28
Ответы и объяснения 1
Var ar : array [1..100] of integer;
i, pluscount,minuscount,zerocount : integer;
begin
readln(n); -считываем число элементов массива(если оно дано, я не знаю)
for i := 1 to n do
begin
read(ar[i]); - считываем элемент массива, заносим его в массив
if (ar[i] > 0) then pluscount := pluscount+1; -если >0 -> увел. счетчик пол.чисел
if (ar[i] < 0) then minuscount := minuscount+1; -если увел. счетчик отр.чисел
if (ar[i] = 0) then zerocount := zerocount+1; -если =0 -> увел. счетчик нулей
end;
writeln('В массиве ',pluscount,' положительных чисел, ',minuscount,' отрицательных чисел, ',zerocount,' нулей.');
end.
- 24.09.2018 04:45
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.