Вопрос по информатике:
Ребята, помогите,пожалуйста))очень нужно
хоть что-нибудь
1)Написать программу на языке программирования Паскаль, вычисляющую гипотенузу и площадь прямоугольного треугольника по двум данным катетам.
2)Заданы площади круга и квадрата. Написать программу, проверяющую поместится ли круг в квадрате.
3)Составить программу вычисления значения переменной у по формуле
у= 234-х^3,при х≤-10
х^2+ 54,при х>-10.
- 20.07.2018 18:12
- Информатика
- remove_red_eye 9720
- thumb_up 39
Ответы и объяснения 1
1. var a, b :real;
begin readln(a, b); writeln(sqrt(a*a + b*b)); end.
2. var s1, s2, a1, a2 :real;
begin readln(s1, s2);
if s1 / 3.14159265 < s2 / 4 then writeln('yes') else writeln('no');
end.
3. var x, y :real;
begin readln(x);
if x < -10 then y:=234 - x*x*x else y:=x * x + 54;
writeln(y);
end.
- 21.07.2018 13:51
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.