Вопрос по информатике:
1)Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру.
2)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
3)Напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя их пробелами.
4)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.
- 01.04.2017 21:11
- Информатика
- remove_red_eye 8511
- thumb_up 49
Ответы и объяснения 1
1)
#include
using namespace std;
void draw_square(int n)
{
for(int y = 0; y < n; y++)
{
for (int x = 0; x < n; x++)
cout << "*";
cout << endl;
}
}
int main()
{
int n;
cin >> n;
draw_square(n);
return 0;
}
2)
#include
using namespace std;
void drawNumbers(int a)
{
while(a > 0)
{
cout << a%10 << endl;
a /= 10;
}
}
int main()
{
int a;
cin >> a;
drawNumbers(a);
return 0;
}
3)
#include
using namespace std;
int main()
{
//можно гораздо быстрей, но мне лень
int a;
cin >> a;
for(int i = 1; i <= a; i++) if(a%i==0) cout << i << " ";
return 0;
}
4)
#include
using namespace std;
void procedure(int a)
{
int b = a;
int c = 1;
while(b > 0) {c *= 10; b/=10;}
while(c > 1)
{
cout << (a%c)/(c/10) << endl;
c /= 10;
}
}
int main()
{
int a;
cin >> a;
procedure(a);
return 0;
}
- 02.04.2017 11:18
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.