Вопрос по информатике:
Помогите решить задачи по паскалю:
1. модифицируйте предыдущий пример, так чтобы программа определяла максимальный и минимальный элемент массива
2. Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (вещественная величина типа real)
Начало:
var a: array[1..10] of integer;
i: integer;
begin
а как дальше?
Предыдущий пример:
var a: array[1..10] of integer;
i: integer;
begin
randomize;
for i:=1 to 10 do
begina[i]:=random(40)-20;
end;
for i:=1write(a[i]:4);
end.
- 13.08.2017 14:23
- Информатика
- remove_red_eye 1870
- thumb_up 45
Ответы и объяснения 1
Const
n = 10;
var
a: array[1..n] of integer;
i, k, min, max: integer;
begin
randomize;
min := 100; max := -100;
Writeln('исходный массив');
for i := 1 to n do
begin
k := random(40) - 20;
a[i] := n;
if max < k then max := k
else if min > k then min := k;
Write(k, ' ')
end;
Writeln;
Writeln('min=', min, ', max=', max)
end.
Тестовое решение:
исходный массив
-8 3 19 -14 19 13 -17 -2 8 8
min=-17, max=19
---------------------------------------------------------
const
n = 10;
var
a: array[1..n] of integer;
i, k, s: integer;
begin
randomize;
s := 0;
Writeln('исходный массив');
for i := 1 to n do
begin
k := random(40) - 20;
a[i] := n; s := s + k;
Write(k, ' ')
end;
Writeln;
Writeln('Среднее арифметическое равно ', s / k)
end.
Тестовое решение:
исходный массив
19 11 -1 1 -4 -6 -2 18 3 8
Среднее арифметическое равно 5.875
- 14.08.2017 16:13
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.