Вопрос по информатике:
Помогите с паскалем...
Задали задание, написать программу формирования одномерного массива размера M. Полученный массив напечатать. Выполнить обработку и проебразование массива в соответствии со своим вариантом ( Вычислить максимальный элемент массива. Заменить в массиве все нечетные на 1. Если нечетных чисел нет, вывести сообщение об этом.) Напечатать проебразованный массив. Подобрать контрольный пример.
- 10.09.2015 11:41
- Информатика
- remove_red_eye 12432
- thumb_up 27
Ответы и объяснения 1
Решение:
const M = 10;
var a : array [1..M] of integer;
i,max, odd : integer;
begin
odd := 0;
{Заполнение массива}
for i := 1 to M do
begin
write('Input a[',i,']:' );
readln(a[i]);
end;
{Вывод массива на экран}
for i := 1 to M do
write(a[i]:2,' ');
writeln;
{Поиск максимального в массиве}
max := a[1];
for i := 2 to M do
if (a[i] > max) then
max := a[i];
writeln('Максимальный элемент массива: ',max);
{Поиск всех нечетных чисел в массиве и замена их на 1}
for i := 1 to M do
if (a[i] mod 2 = 1) then
begin
a[i] := 1;
odd := 666;
end;
{Вывод сообщения об отсутствии нечетных чисел}
if (odd = 0) then
writeln('В массиве нечетных чисел нет');
{Вывод преобразованного массива}
for i := 1 to M do
write(a[i]:2,' ');
writeln;
readln;
end.
В фигурных скобках - комментарии, из программы можно удалять безболезненно. M - количество элементов в массиве.
Контрольные примеры для массива из 10 элементов:
1) Массив "1 2 3 4 5 6 7 8 9 10" будет преобразован в "1 2 1 4 1 6 1 8 1 10", максимальный элемент (до преобразования) 10
2) Массив " 2 2 2 2 2 2 2 2 2 2" будет преобразован в " 2 2 2 2 2 2 2 2 2 2", на экран будет выведено сообщение "в массиве нечетных чисел нет", максимальный элемент 2
- 11.09.2015 03:21
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.