Вопрос по информатике:
Составить программу вычисления суммы квадратов первых N членов натурального ряда, каждое из которых при делении на M дает в остатке F. (Паскаль)
- 07.03.2018 01:36
- Информатика
- remove_red_eye 10180
- thumb_up 22
Ответы и объяснения 1
Var x, n, m, f, s: integer;
begin
write('Введите N: '); readln(n);
write('Введите M: '); readln(m);
write('Введите F: '); readln(f);
for x := 1 to n do
if(x mod m = f) then s := s + sqr(x);
writeln('Сумма: ', s);
end.
- 08.03.2018 13:26
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.