Вопрос по информатике:
Составить программу в PASCAL.
Ввести размерность матрицы и значения ее элементов.
Определить максимальный и минимальный элемент. Переставить их местами.
Найти среднее арифметическое отрицательных элементов в i-ой строке.
- 26.12.2017 22:15
- Информатика
- remove_red_eye 7164
- thumb_up 14
Ответы и объяснения 1
Var
m,n,i,j,max,min,imx,imn,jmn,jmx,k,p:integer;
s:real;
a:array[,]of integer;
begin
write('Число строк: ');
readln(m);
write('Число столбцов: ');
readln(n);
setlength(a,m+1,n+1);
for i:=1 to m do
begin
writeln('Вводите элементы строки ',i,' по одному');
for j:=1 to n do readln(a[i,j]);
end;
min:=a[1,1];
max:=a[1,1];
imn:=1;
jmn:=1;
imx:=1;
jmx:=1;
for i:=1 to m do
for j:=1 to n do
begin
if a[i,j]
min:=a[i,j];
imn:=i;
jmn:=j;
end;
if a[i,j]>max then
begin
max:=a[i,j];
imx:=i;
jmx:=j;
end;
end;
p:=a[imn,jmn];
a[imn,jmn]:=a[imx,jmx];
a[imx,jmx]:=p;
writeln('Измененный массив:');
for i:=1 to m do
begin
for j:=1 to n do write(a[i,j]:5);
writeln;
end;
write('Введите номер строки: ');
readln(i);
for j:=1 to n do
if a[i,j]<0 then
begin
s:=s+a[i,j];
k:=k+1;
end;
writeln('Ср.ариф. отр.чисел в строке: ',s/k);
end.
- 27.12.2017 09:33
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.