Вопрос по информатике:
ЯЗЫК СИ. Написать программу заполнения односвязного списка значениями и вывода этих значений. Помогите, пожалуйста.
- 02.05.2015 00:14
- Информатика
- remove_red_eye 12122
- thumb_up 16
Ответы и объяснения 1
выбирай
#include
#include
struct LIST {
int number;
struct LIST *next; };
//-----------------------------------------------------------------------------
void Push(struct LIST** list, int number) {
struct LIST* node = malloc(sizeof(struct LIST));
node->number = number;
node->next = *list;
*list = node; }
//-----------------------------------------------------------------------------
void Print(const struct LIST* list) {
if (list) {
Print(list->next);
printf("%d ", list->number); } }
//-----------------------------------------------------------------------------
int main() {
int i = 10;
struct LIST* list = NULL;
while (i--) {
Push(&list, i + 1); }
//---(это разделение разных программ)
- 03.05.2015 01:18
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.