Вопрос по информатике:
Помогите пожалуйста написать программу на паскале. Даны натуральное число N и действительное число X.Вычислить:tg X+tg tg X+tg tg tg X+...+tg tg...tg X.
- 03.05.2018 20:52
- Информатика
- remove_red_eye 14362
- thumb_up 7
Ответы и объяснения 1
Var
n, i: integer;
x, ans, s: real;
begin
readln(n, x);
ans := tg(x);
s = ans;
for i := 2 to n do
begin
ans := tg(ans);
s := s + ans;
end;
writeln(s);
end.
- 04.05.2018 06:59
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.