Вопрос по информатике:
Дан целочисленный массив a размера n. Вывести порядковый номер последнего из тех его элементов ak, которые удовлетворяют двойному неравенству a1 < ak < a10. Если таких элементов нет, то вывести 0.
Входные данные: ввести одно целое число n. (1<=n<=1000). Далее ввести n чисел в диапазоне от -1000 до 1000.
Выходные данные: вывести порядковый номер последнего из тех его элементов ak, которые удовлетворяют двойному неравенству a1 < ak < an. Если таких элементов нет, то вывести 0.
- 08.07.2018 00:32
- Информатика
- remove_red_eye 2733
- thumb_up 51
Ответы и объяснения 1
#include
int main()
{
// Считываем.
int n;
std::cin >> n;
int * a = new int[n];
int t;
int i = 0;
while (n - i){
if (std::cin >> t){
a[i++] = t;
}
}
// Находим и выводим.
n--;
int max = -1;
for (i = n-1; i >= 0; --i){
if (a[i] > *a && a[i] < a[n]){
max = i;
break;
}
}
std::cout << max+1 << std::endl;
delete [] a;
std::cin.get();
std::cin.get();
return 0;
}
- 09.07.2018 19:34
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.