Вопрос по информатике:
Составить программу для сортировки методом сплошного просмотра по убыванию произвольного массива G(N). Отсортировать массив А(10) методом пузырька по возрастанию.
пожалуйста=***
- 15.06.2018 12:37
- Информатика
- remove_red_eye 19317
- thumb_up 13
Ответы и объяснения 1
Исходный код на С++:
#include
using namespace std;
int main()
{
int size;
cin >> size;
int *a = new int[size];
for (int i = 0; i < size; i++)
{
cin >> a[i];
}
for (int i = 0; i < size; i++)
{
for (int j = size - 1; j > i; j--)
{
if (a[j] < a[j - 1])
{
swap (a[j], a[j - 1]);
}
}
}
for (int i = 0; i < size; i++)
{
cout << a[i] << ' ';
}
return 0;
}
- 16.06.2018 04:30
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.