Вопрос по информатике:
А)Одномерный массив A заполнен десятью случайными целыми числами от 1 до 20. Напишите программу вывода элементов массива в обратном порядке.
б)Напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.
- 27.05.2016 20:57
- Информатика
- remove_red_eye 4619
- thumb_up 35
Ответы и объяснения 1
А)
var
a:array[1..10]of integer;
i:integer;
begin
for i:=1 to 10 do
a[i]:=random(20)+1;
for i:=10 downto 1 do
write(a[i],' ');
end.
б)
var
a:array[1..20]of integer;
i:integer;
begin
for i:=1 to 20 do
a[i]:=random(11*i)+10*i;
for i:=1 to 20 do
if i mod 2=1 then write(a[i],' ');
end.
- 28.05.2016 14:32
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.