Вопрос по информатике:
Дано натуральное число n,
a. Сколько цифр в числе n?
b. Сколько чётных цифр в числе n?
- 14.11.2017 00:55
- Информатика
- remove_red_eye 17178
- thumb_up 37
Ответы и объяснения 1
#include
#include
int main()
{
int n;
std::cin >> n;
int count =0, even=0;
std::strstream str;
str << n;
char ch;
while (str.get(ch)){
count++;
even += ((ch % 2) + 1) % 2;
}
std::cout << "The number of digits " << count << " of them even " << even << std::endl;
return 0;
}
- 14.11.2017 01:45
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.