Вопрос по информатике:
Для того чтобы выходить в Интернет, каждому компьютеру присваивается так называемый IP-адрес. Он состоит из четырех целых чисел в диапазоне от 0 до 255, разделенных точками. В следующих трех строках показаны три правильных IP-адреса:
127.0.0.0
192.168.0.01
255.00.255.255
Напишите программу, которая определяет, является ли заданная строка правильным IP-адресом.
Формат входного файла:
На вход программе подается строка длиной не более 15 символов, которая включает цифры и ровно три точки.
Формат выходного файла:
Если строка является правильным IP-адресом, необходимо вывести 1, иначе 0.
- 02.11.2017 18:22
- Информатика
- remove_red_eye 18946
- thumb_up 50
Ответы и объяснения 1
Program ip;
var s,s1:string;
i,j,x,err:integer;
f:boolean;
begin
readln(s);
i:=1; j:=1; f:=true;
while (j<4) and f do
begin
while s[i]'.' do
begin
s1:=s1+s[i];
inc(i);
end;
val(s1,x,err);
f:=x<256;
delete(s1,1,length(s1));
inc(j);
end;
if f then
begin
while i<=length(s1) do
begin
s1:=s1+s[i];
inc(i);
end;
f:=x<256;
end;
if f then writeln(1) else writeln(0);
end.
- 03.11.2017 00:28
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.