Вопрос по информатике:
ПОМОГИТЕ ПОЖАЛУЙСТА!!!! Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран. Если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. Иначе, найдите и выведите среднее арифметическое этих чисел.
- 17.02.2018 16:13
- Информатика
- remove_red_eye 14483
- thumb_up 25
Ответы и объяснения 1
Program A1;
var
N,M,K:real;
Begin
writeln('Введите числа N и M');
readln(N,M);
If N>100 and M>100 then
N:=N-1;
M:=M-1;
writeln(M,N);
If N>0 and M<0 then
N:=N/2;
M:=M/2;
writeln(N,M)
Else
K:=0;
K:=(M+N)/2;
writeln(K);
End.
- 18.02.2018 03:39
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.