Вопрос по информатике:
Написать программу для "Pascal":
Дана целочисленная матрица размерности (NxM). Поменять местами строки с max и min элементами.
- 25.05.2018 10:22
- Информатика
- remove_red_eye 2813
- thumb_up 22
Ответы и объяснения 1
Program n1;
const maxm = 50;
maxn = 50;
var a:array[1..maxm,1..maxn] of integer;
min,max,i,j,n,m,x,maxi,mini:integer;
begin
write('Введите размеры матрицы (N*M): ');
readln(n,m);
writeln('Введите матрицу из ',n,' строк и ',m,' столбцов:');
min:=maxint; max:=-maxint-1;
for i:=1 to n do
for j:=1 to m do
begin
read(a[i,j]);
if a[i,j]>max then begin max:=a[i,j]; maxi:=i; end;
if a[i,j]
for j:=1 to m do
begin
x:=a[maxi,j]; a[maxi,j]:=a[mini,j]; a[mini,j]:=x;
end;
writeln('Матрица после преобразования:');
for i:=1 to n do
begin
for j:=1 to m do
write(a[i,j],' ');
writeln;
end;
end.
- 26.05.2018 19:52
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.