Вопрос по информатике:
Решение задач с использованием строк
1. Составьте программу, которая:
а) из слова «КОМПИЛЯТОР» составляет слова: «МОТОР», «КОМОК», «ПИЛОТ»;
б) из слов «МАНДАРИН», «МОДА», «МАК» получает слово «КОМАНДОР»;
в) заменяет в тексте, заданном с клавиатуры, пробелы между словами подчеркиванием.
- 14.03.2018 04:07
- Информатика
- remove_red_eye 8961
- thumb_up 28
Ответы и объяснения 1
Var
str, s, s1, s2, s3: string;
i:integer;
begin
str:='ÊÎÌÏÈËßÒÎÐ';
s:=str[3]+str[2]+copy(str, 8, 3);
writeln(s);
s:=copy(str, 1, 3)+str[2]+str[1];
writeln(s);
s:=copy(str, 4, 3)+str[2]+str[length(str)-2];
writeln(s);
s1:='ÌÀÍÄÀÐÈÍ'; s2:='ÌÎÄÀ'; s3:='ÌÀÊ';
s:=copy(s3, 3, 1)+copy(s2, 2, 1)+copy(s1, 1, 4)+copy(s2, 2, 1)+copy(s1, length(s1)-2, 1);
writeln(s);
writeln('Vvedite stroku:');
readln(str);
for i:=1 to length(str) do
if str[i]=' ' then str[i]:='_';
writeln(str);
end.
- 15.03.2018 17:01
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.