Вопрос по информатике:
Дан массив из N целых чисел.Написать программу,определяющую,максимальный элемент массива и его номер.
- 15.01.2015 01:18
- Информатика
- remove_red_eye 13540
- thumb_up 42
Ответы и объяснения 2
C++:
#Include
using namespace std;
int main()
{
int N;
cin >> N;
int a;
cin >> a;
int max = a;
for(int i = 1; i < N; i++)
{
cin >> a;
if(a > max) max = a;
}
cout << max << endl;
return 0;
}
//Тут технически без массива(он не хранится в памяти программы), на самом деле он тут не особо нужен.
- 16.01.2015 00:45
- thumb_up 28
Pascal:
a: array [1..10000] of integer;
i, n, m: integer;
begin
readln(n);
for i := 1 to n do
read(a[i]);
m := 1;
for i := 2 to n do
if (a[i] > a[m])
then m := i;
writeln(a[m],' ',m);
end.
- 17.01.2015 22:35
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.