Вопрос по информатике:
Напишите программу формирования и вывода массива произвольного размера так, чтобы каждый последующий элемент, начиная с третьего, был равен сумме двух предыдущих элементов. Два первых элемента задайте с клавиатуры.
Напишите программу формирования и вывода массива размером 6х3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й - равен случайному числу, отличному от нуля;
2-й - равен квадрату предыдущего элемента;
3-й - равен целой части частного от деления двух предыдущих элементов.
- 23.06.2017 11:13
- Информатика
- remove_red_eye 628
- thumb_up 47
Ответы и объяснения 1
1. var a:array [1..100] of integer;
i,n:integer;
begin
read(n); {количество эл. массива}
read (a[1], a[2]);
for i:=3 to n do
a[i]:=a[i-1]+a[i-2];
for i:=1 to n do
write (a[i],' ' );
end.
2.const m=6;n=3;
var a:array [1..100,1..100] of integer;
i,j:integer;
begin
for i:=1 to m do
read (a[i,1]);
for i:=1 to m do
begin
j:=1;
a[i,j+1]:= sqr(a[i,j]);
a[i,j+2]:= a[i,j] div a[i,j+1]; {это условие мне не совсем понятно}
end;
for i:=1 to m do
begin
for j:=1 to n do
write (a[i,j]:3);
writeln;end;
end.
- 24.06.2017 10:57
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.