Вопрос по информатике:
Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. Если отрицательных элементов нет, то сообщить об этом)
p.s. В паскале
- 12.07.2018 21:54
- Информатика
- remove_red_eye 7739
- thumb_up 41
Ответы и объяснения 1
Var
n, i, s, k:integer;
a:array [1..30] of integer;
begin
writeln('Vvedite massiv');
for i:=1 to 30 do
readln(a[i]);
writeln('Massiv');
for i:=1 to 30 do
write(a[i],' ');
writeln();
k:=0; s:=0;
for i:=1 to 30 do
if a[i]<0 then
begin
s:=a[i]+s;
k:=1;
end;
if k=1 then
writeln('Summa otricatelnih elementov: ',s)
else
writeln('Otricatelnih elementov net');
readln();
end.
- 13.07.2018 00:44
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.