Вопрос по информатике:
2. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K. Протестировать программу на следующих исходных данных:
а) k=3 Массив: 2 6 -9 4 5 12 -15
б) k=4 Массив: 9 0 8 124 -16 11 19
НА ПАСКАЛЕ
- 08.03.2018 14:05
- Информатика
- remove_red_eye 11212
- thumb_up 30
Ответы и объяснения 1
Var
a:array [1..100000] of integer;
i,n,k:integer;
begin
writeln('Введите n и k');
readln(n,k);
for i:=1 to n do
begin
writeln('Введите элемент №',i);
readln(a[i]);
end;
writeln('Весь массив:');
for i:=1 to n do
write(a[i],' ');
writeln();
writeln('Числа кратные ',k,':');
for i:=1 to n do
if a[i] mod k = 0 then
write(a[i],' ');
end.
ТЕСТ №1:
Весь массив:
2 6 -9 4 5 12 15
Числа кратные 3:
6 -9 12 15
ТЕСТ №2:
Весь массив:
9 0 8 124 -16 11 19
Числа кратные 4:
0 8 124 -16
- 09.03.2018 11:50
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.