Вопрос по информатике:
Составить программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2;3), и подсчитывает сумму отрицательных чисел. Вывод в столбец с двумя десятичными знаками.
- 12.08.2018 13:04
- Информатика
- remove_red_eye 12981
- thumb_up 13
Ответы и объяснения 1
Program Program1;
var
i:integer;
sum:real;
a:array [1..16] of real;
begin
randomize;
for i:=1 to 16 do
begin
a[i]:=-2 + Random * 5;
writeln('a[',i,']=',a[i]:0:2);
end;
sum:=0;
for i:=1 to 16 do
if a[i]<0 then sum:=sum+a[i];
writeln('Сумма отрицательных чисел равна',sum:0:2);
end.
- 13.08.2018 08:57
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.