Вопрос по информатике:
Помогите пожалуйста! Нужно вытянуть оценку!!!
Напишите процедуру ввода N элементов массива из файла. Отсортируйте по невозрастанию методом простого обмена. (Паскаль)
- 03.05.2018 07:32
- Информатика
- remove_red_eye 5255
- thumb_up 22
Ответы и объяснения 1
Var i,j,n,k: integer;
a: array [1..100] of integer;
begin
assign (input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
readln (n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
for j:=1 to n-i do
if a[j+1]>a[j]
then begin k:=a[j]; a[j]:=a[j+1]; a[j+1]:=k; end;
for i:=1 to n do
write (a[i],' ');
end.
Входные данные писать в файл input.txt в формате:
n
a[i] a[i+1] a[i+2]...a[n].
- 04.05.2018 23:51
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.