Вопрос по информатике:
Найти алгоритм решения задачи и реализовать его с помощью оператора(операторов) if-then-else. В Атлантическом океане терпит бедствие пассажирский теплоход ”Посудина”. Все пассажиры будут спасены, если на помощь успеют два судна. Судно продержится на плаву t часов. Скорость судов-спасателей 40 узлов. Составить программу, определяющую спасутся ли пассажиры. Известны расстояния от трех судов-спасателей до тонущего судна.
- 13.11.2017 14:31
- Информатика
- remove_red_eye 2007
- thumb_up 25
Ответы и объяснения 1
Const
v=40;
var
t,r1,r2,r3:real;
n:integer;
begin
write('Сколько часов продержатся пассажиры? ');
readln(t);
write('Введите расстояния до трех спасателей (в узлах): ');
readln(r1,r2,r3);
if r1/v
else
if n>0 then writeln('Спасется половина пассажиров')
else writeln('Никто не спасется')
end.
- 14.11.2017 02:43
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.