Вопрос по информатике:
Помогите пожалуйста)
1)Оценки в соревнованиях по фигурному катанию выставляются 9 судьями.Потом одна самая низкая и одна самая высокая оценки отбрасываются и в зачет идет среднее арифметическое оставшихся оценок.Составьте программу,которая определяет зачетную оценку спортсмена.Оценки судей ввести с клавиатуры(целые числа от 1 до 6).
2)Составьте программу,которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент массива среди элементов с четными индексами.
3)Составьте программу,которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди элементов с нечетными индексами.
4)Составьте программу,которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве.
5)Составьте программу,которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 0 до 10 и находит сумму минимального и максимального элементов массива.
- 09.11.2015 23:51
- Информатика
- remove_red_eye 19368
- thumb_up 46
Ответы и объяснения 1
1.var
max,min,i:integer;
b:real;
a:array[1..9]of integer;
begin
for i:=1 to 9 do
begin
while (a[i]6) do
begin
write(i,' оценка: ');
readln(a[i]);
end;
if i=1 then
begin
max:=a[1];
min:=a[1];
end;
if a[i]>max then max:=a[i];
if a[i]
end;
b:=(b-min-max)/7;
writeln('Зачетная оценка: ',b);
end.
2. #include
#include
#include
#include //for rand;
int main()
{
int i, n,M[1];
printf("Vvedit N:");
scanf("%d",&n);
for (i = 0; i < n; i++)
{
M[i] = rand()%10;
}
for (i = 0; i < n; i++)
{
printf("Array[%d] = %d\n", i, M[i]);
}
scanf("%d");
return 0;
}
3. var
a:array[0..9] of integer;
i,y,min:integer;
begin
randomize();
for i:=0 to 9 do
begin
y:= random(10);
a[i]:= y;
end;
for i:=0 to 9 do write(a[i],' ');
writeln(' - десять випадковых чисел');
min:=a[0];
for i:=1 to 9 do
if a[i]
end.
- 01.01.1970 00:00
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.