Вопрос по информатике:
Составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Выведите на экран исходный и полученный массивы!
- 26.12.2017 00:06
- Информатика
- remove_red_eye 2441
- thumb_up 51
Ответы и объяснения 1
Var a:array [1..10] of integer;
b:array [1..10] of integer;
i:integer;
begin
randomize;
for i:=1 to 10 do
a[i]:=random(10);
for i:=1 to 10 do
write(a[i],' ');
writeln;
i:=1;
while i<=9 do
begin
b[i]:=a[i]*3;
i:=i+2;
end;
i:=2;
while i<=10 do
begin
b[i]:=a[i]*2;
i:=i+2;
end;
for i:=1 to 10 do
write(b[i],' ');
end.
- 27.12.2017 14:46
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.