Вопрос по информатике:
Помогите написать программу Pascal!
При поступлении в институт абитуриенты получившие "двойку" за первый экзамен,не допускаются до второго. Дан список абитуриентов и их оценки на первом экзамене. Составьте список абитуриентов допущенных ко 2 экзамену.
Дано:
n:=10
Массив А-Фамилии(записываются вручную)-string
Массив B-оценки random(4)+1
Найти: Массив С[j]-string
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 14.10.2016 03:21
- Информатика
- remove_red_eye 8740
- thumb_up 8
Ответы и объяснения 1
Const n=10;
var a:array [1..n] of string;
b:array [1..n] of Integer;
c:array [1..n] of string;
i,j:Integer;
begin
Randomize;
for i:=1 to n do
readln(a[i]);
for i:=1 to n do
b[i]:=random(4)+1;
for i:=1 to n do
begin
if b[i]>2 then
begin
c[i]:=a[i];
write(c[i],'-',b[i],' ');
end;
end;
Readln;
end.
- 15.10.2016 19:34
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.