Вопрос по информатике:
Помогите написать программу на Pascal для определения в двумерном массиве вещественных чисел D [7, 7] суммы всех элементов на главной диагонали.
- 23.09.2016 23:47
- Информатика
- remove_red_eye 9956
- thumb_up 31
Ответы и объяснения 1
VAR D : array [1..7,1..7] of real; s: real; i,j: Byte;
begin
s:=0;
FOR i:=1 TO 7 DO
FOR j:=1 TO 7 DO D[ i,j]:= RANDOM(10);
FOR i:=1 TO 7 DO
begin
FOR j:=1 TO 7 DO
WRITE ( D[ i,j]);WRITEln();
end;
FOR i:=1 TO 7 DO
FOR j:=1 TO 7 DO if i=j then s:=s+D[i,j];
WRITEln('s=',s);
end.
- 24.09.2016 15:43
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.