Вопрос по информатике:
Составьте программу, которая заполняет массив A[1..10] случайными целыми числами в диапазоне от -20 до 20, затем меняет местами первый элемент с максимальным элементом. Выведите на экран исходный и полученный массивы.
- 22.02.2018 00:33
- Информатика
- remove_red_eye 13095
- thumb_up 26
Ответы и объяснения 1
Const
n=10;
var
a:array[1..n] of integer;
i, MAX,t:integer;
begin
randomize;
writeln('Исходный массив:');
for i:=1 to n do
begin
A[i]:=random(40)-20;
writeln(a[i]);
end;
MAX:=-20-1;
for i:=1 to n do
if A[i]>MAX
then
MAX:=A[i];
t:=A[1]; //Замена
A[1]:=MAX;
MAX:=t;
Writeln('Готовый массив:');
for i:=1 to n do
writeln(A[i]);
end.
- 23.02.2018 15:51
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.