Вопрос по информатике:
Напишите программу увеличивающую каждый элемент матрицы (n,m) в 3 раза и сохраняющую результат в виде второй матрицы
- 11.05.2018 16:09
- Информатика
- remove_red_eye 12393
- thumb_up 22
Ответы и объяснения 1
Uses
CRT;
Const
nmax=40;
mmax=40;
var a,b:array[1..nmax,1..mmax] of integer;
i,j,n,m:integer;
begin
ClrScr;
repeat
write('N:=');
Readln(n);
until n in [1..nmax];
repeat
write('M:=');
Readln(m);
until m in [1..mmax];
writeln('Исходный массив: ');
randomize;
for i:=1 to n do
begin
for j:=1 to m do begin
a[i,j]:=random(10)-3;
write(a[i,j]:5);
b[i,j]:=a[i,j]*a[i,j]*a[i,j];
end;
writeln;
end;
writeln('Результирующий массив: ');
for i:=1 to n do
begin
for j:=1 to m do
begin
write(b[i,j]:5);
end;
writeln;
end;
readkey
end.
- 12.05.2018 03:31
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.